---
id: CVE-2026-103294
title: >-
  CAI Content Credentials is affected by an Improper Certificate Validation
  vulnerability that could result in a Security feature bypass
summary: >-
  CAI Content Credentials is affected by an Improper Certificate Validation
  vulnerability that could result in a Security feature bypass. An attacker
  could leverage this vulnerability to bypass security measures and gain
  unauthorized write…
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N'
cwe:
  - CWE-295
vendor: adobe
product: c2pa
affected:
  - c2pa < 0.91.1
  - c2pa-web < 0.15.3
  - c2patool < 0.28.1
patched:
  - c2pa 0.91.1
  - c2pa-web 0.15.3
  - c2patool 0.28.1
published: '2026-10-13'
updated: '2026-10-17'
sourceUpdated: '2026-10-17T02:17:09.293'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-103294'
references:
  - url: >-
      https://www.adobe.com/trust/security/products/content-credentials-sdk/apsb26-163.html
    label: psirt@adobe.com
tags:
  - nvd
  - cve.org
epss: 0.00199
epssPercentile: 0.09615
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-17T00:53:01.663543Z'
ingestedAt: '2026-10-13T23:03:54.732Z'
---

## Overview

CAI Content Credentials is affected by an Improper Certificate Validation vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized write access. Exploit depends on conditions beyond the attacker's control. Exploitation of this issue does not require user interaction.

## Affected

- `c2pa < 0.91.1`
- `c2pa-web < 0.15.3`
- `c2patool < 0.28.1`

## Remediation

Upgrade past the affected range:

- `c2pa 0.91.1`
- `c2pa-web 0.15.3`
- `c2patool 0.28.1`
