---
id: CVE-2026-103309
title: >-
  The GPTranslate  WordPress plugin before 2.34.14 does not properly restrict
  who can store translations, and does not escape them when outputting them in
  translated pages, allowing unauthenticated users to perform Stored Cross-Site
  Script…
summary: >-
  The GPTranslate  WordPress plugin before 2.34.14 does not properly restrict
  who can store translations, and does not escape them when outputting them in
  translated pages, allowing unauthenticated users to perform Stored Cross-Site
  Script…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-79
product: GPTranslate
affected:
  - GPTranslate < 2.34.14
published: '2026-10-08'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T20:51:18.123'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-103309'
references:
  - url: 'https://wpscan.com/vulnerability/e791e349-932b-4e59-bacb-a49b57343cf3/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-08T10:58:20.316039Z'
ingestedAt: '2026-10-08T07:18:54.835Z'
epss: 0.00267
epssPercentile: 0.18734
---

## Overview

The GPTranslate  WordPress plugin before 2.34.14 does not properly restrict who can store translations, and does not escape them when outputting them in translated pages, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks when server-side translations are enabled.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
