---
id: CVE-2026-103478
title: >-
  The Premium Packages – Sell Digital Products Securely plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via the 'checkout[billing][phone]
  (and state / taxid / email)' parameter in all versions up to, and including,
  7.2.6 …
summary: >-
  The Premium Packages – Sell Digital Products Securely plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via the 'checkout[billing][phone]
  (and state / taxid / email)' parameter in all versions up to, and including,
  7.2.6 …
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
published: '2026-10-10'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T13:30:21.620'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-103478'
references:
  - url: 'https://plugins.trac.wordpress.org/browser/wpdm-premium-packages/'
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/wpdm-premium-packages/tags/7.2.6/src/Customer/BillingInfoService.php#L190
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/wpdm-premium-packages/tags/7.2.6/src/Customer/BillingInfoService.php#L265
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/wpdm-premium-packages/tags/7.2.6/src/Customer/BillingInfoService.php#L424
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/wpdm-premium-packages/tags/7.2.6/templates/dashboard/billing-info.php#L108
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/wpdm-premium-packages/tags/7.2.6/templates/dashboard/billing-info.php#L115
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/wpdm-premium-packages/tags/7.2.6/templates/dashboard/billing-info.php#L125
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/wpdm-premium-packages/tags/7.2.6/templates/dashboard/billing-info.php#L132
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3724154/wpdm-premium-packages/trunk/templates/dashboard/billing-info.php
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/e961f5b3-0efc-40c7-87a8-48290357dd2e?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00298
epssPercentile: 0.22334
ingestedAt: '2026-10-10T08:27:37.784Z'
vendor: codename065
product: Premium Packages – Sell Digital Products Securely
affected:
  - premium_packages_sell_digital_products_securely <= 7.2.6
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-11T12:11:11.873018Z'
---

## Overview

The Premium Packages – Sell Digital Products Securely plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'checkout[billing][phone] (and state / taxid / email)' parameter in all versions up to, and including, 7.2.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
