---
id: CVE-2026-103479
title: >-
  Pubjet | پاب‌جت <= 5.4.8 - Authenticated (Subscriber+) Privilege Escalation to
  'check-token' AJAX Action
summary: >-
  The Pubjet | پاب‌جت plugin for WordPress is vulnerable to Privilege Escalation
  in all versions up to, and including, 5.4.8. This is due to the `checkToken()`
  AJAX handler — registered under `wp_ajax_pubjet-check-token` — performing no
  ca…
severity: high
cvss: 7.6
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L'
cvssSource: cna
cwe:
  - CWE-269
vendor: pubjet
product: Pubjet | پاب‌جت
affected:
  - Pubjet_|_پاب‌جت <= 5.4.8
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-06T17:32:50.839014Z'
published: '2026-11-06'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T17:33:03.308Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-103479'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/0391145a-2707-4639-80d0-a8a98512ef66?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/pubjet/tags/5.4.8/includes/Ajax.php#L643
  - url: >-
      https://plugins.trac.wordpress.org/browser/pubjet/tags/5.4.8/includes/Ajax.php#L631
  - url: >-
      https://plugins.trac.wordpress.org/browser/pubjet/tags/5.4.8/includes/Ajax.php#L26
  - url: >-
      https://plugins.trac.wordpress.org/browser/pubjet/tags/5.4.8/includes/RestApi.php#L374
  - url: >-
      https://plugins.trac.wordpress.org/browser/pubjet/tags/5.4.8/includes/RestApi.php#L363
tags:
  - cve.org
ingestedAt: '2026-11-06T11:50:33.396Z'
epss: 0.00375
epssPercentile: 0.31636
---

## Overview

The Pubjet | پاب‌جت plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 5.4.8. This is due to the `checkToken()` AJAX handler — registered under `wp_ajax_pubjet-check-token` — performing no capability check and no nonce verification before unconditionally writing the attacker-supplied `token` GET parameter directly into the site-wide `pubjet_settings` option via `pubjet_update_setting()`, prior to any remote validation. This makes it possible for authenticated attackers, with Subscriber-level access and above, to overwrite the plugin's stored REST API credential with an attacker-chosen value, immediately elevating their effective privileges to those of an authorized Pubjet API client and enabling them to invoke otherwise-restricted endpoints — `createReportage`, `updateReportage`, `deleteReportage`, `toggleCopyright`, and `createBacklink` — to create, modify, and delete arbitrary reportage posts and manipulate plugin state that Subscribers cannot normally access. The privilege escalation is self-reinforcing: because `RestApi::isTokenValid()` authenticates solely by comparing the incoming `Authorization` header against the value returned by `pubjet_token()`, which reads from the same option the unprotected handler writes to, the attacker-planted token is trusted as legitimate on all subsequent requests.

## Affected

- `Pubjet_|_پاب‌جت <= 5.4.8`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
