---
id: CVE-2026-103518
title: >-
  The FluentCart A New Era of eCommerce – Faster, Lighter, and Simpler plugin
  for WordPress is vulnerable to generic SQL Injection via the
  'products[*].variants[*].<attacker-chosen key>' parameter in all versions up
  to, and including, 1.7.…
summary: >-
  The FluentCart A New Era of eCommerce – Faster, Lighter, and Simpler plugin
  for WordPress is vulnerable to generic SQL Injection via the
  'products[*].variants[*].<attacker-chosen key>' parameter in all versions up
  to, and including, 1.7.…
severity: medium
cvss: 4.9
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-89
vendor: wpmanageninja
product: 'FluentCart A New Era of eCommerce – Faster, Lighter, and Simpler'
affected:
  - fluentcart_a_new_era_of_ecommerce_faster_lighter_and_simpler <= 1.7.0
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:02.147'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-103518'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/fluent-cart/tags/1.7.0/api/Resource/ProductResource.php#L304
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/fluent-cart/tags/1.7.0/app/Http/Controllers/ProductController.php#L1818
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/fluent-cart/tags/1.7.0/app/Models/BatchQuery/Batch.php#L103
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/fluent-cart/tags/1.7.0/app/Models/Concerns/CanUpdateBatch.php#L14
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/fluent-cart/tags/1.7.0/app/Services/BulkProductUpdateService.php#L413
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3734886/fluent-cart/trunk/app/Models/BatchQuery/Batch.php
    label: security@wordfence.com
  - url: 'https://wordpress.org/plugins/fluent-cart/'
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/094a768d-85f8-4b6a-8aa3-e243f2e4b505?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00377
epssPercentile: 0.31469
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:50:33.248787Z'
ingestedAt: '2026-10-16T03:57:49.271Z'
---

## Overview

The FluentCart A New Era of eCommerce – Faster, Lighter, and Simpler plugin for WordPress is vulnerable to generic SQL Injection via the 'products[*].variants[*].<attacker-chosen key>' parameter in all versions up to, and including, 1.7.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with custom-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. On FluentCart Pro installs, non-administrator users assigned the Manager shop role also hold the products/edit permission and are therefore able to exploit this vulnerability without administrator-level access.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
