---
id: CVE-2026-103524
title: >-
  Thelia v2.6.0 is vulnerable to multiple stored XSS vulnerabilities within the
  administrative interface
summary: >-
  Thelia v2.6.0 is vulnerable to multiple stored XSS vulnerabilities within the
  administrative interface. User-supplied input is stored without sufficient
  output encoding or sanitization and is later rendered in the administrator
  interface…
severity: medium
cvss: 4.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: Thelia
product: Thelia
affected:
  - Thelia <= 2.6.0
published: '2026-10-12'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T18:17:18.410'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-103524'
references:
  - url: 'https://kb.cert.org/vuls/id/162329'
    label: cret@cert.org
tags:
  - nvd
  - cve.org
epss: 0.0023
epssPercentile: 0.13802
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T17:16:24.291639Z'
ingestedAt: '2026-10-12T15:55:08.154Z'
---

## Overview

Thelia v2.6.0 is vulnerable to multiple stored XSS vulnerabilities within the administrative interface. User-supplied input is stored without sufficient output encoding or sanitization and is later rendered in the administrator interface and/or the web store's product pages, allowing arbitrary JavaScript execution when the affected pages are viewed. The vulnerability affects multiple administrative functions including category creation and product creation.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
