---
id: CVE-2026-103996
title: >-
  If-So Dynamic Content <= 1.10.2 - Authenticated (Contributor+) Stored
  Cross-Site Scripting via ifso-redirect Shortcode 'url' Attribute
summary: >-
  The If-So Dynamic Content – Elementor & All Page Builders Personalization
  plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the
  'url' parameter in all versions up to, and including, 1.10.2 due to
  insufficient input sa…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: ifso
product: If-So Dynamic Content – Elementor & All Page Builders Personalization
affected:
  - if-so_dynamic_content_elementor_all_page_builders_personalization <= 1.10.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-28T14:35:59.368233Z'
published: '2026-10-28'
updated: '2026-10-28'
sourceUpdated: '2026-10-28T16:10:28.642Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-103996'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/177aca03-683b-48e1-911f-c966b171626b?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/if-so/tags/1.10.2/extensions/ifso-extended-shortcodes/extended-shortcodes.php#L469
  - url: >-
      https://plugins.trac.wordpress.org/browser/if-so/tags/1.10.2/extensions/ifso-extended-shortcodes/extended-shortcodes.php#L455
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3748902%40if-so&new=3748902%40if-so
tags:
  - cve.org
epss: 0.00243
epssPercentile: 0.15559
ingestedAt: '2026-10-28T07:06:27.126Z'
---

## Overview

The If-So Dynamic Content – Elementor & All Page Builders Personalization plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'url' parameter in all versions up to, and including, 1.10.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected script executes specifically in the administrator's browser session, as the vulnerable branch only renders when an administrator previews or opens the post containing the crafted shortcode.

## Affected

- `if-so_dynamic_content_elementor_all_page_builders_personalization <= 1.10.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
