---
id: CVE-2026-103997
title: >-
  Redux Framework <= 4.5.15 - Missing Authorization to Authenticated
  (Subscriber+) Sensitive Information Disclosure via /wp-admin/profile.php
  inline redux_<opt_name> JavaScript
summary: >-
  The Redux Framework plugin for WordPress is vulnerable to authorization bypass
  in all versions up to, and including, 4.5.15. This is due to the plugin not
  properly verifying that a user is authorized to perform an action. This makes
  it p…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-862
vendor: davidanderson
product: Redux Framework
affected:
  - redux_framework <= 4.5.15
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-06T18:36:57.741809Z'
published: '2026-10-31'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T18:37:09.445Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-103997'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/b1dd83e6-ea48-459b-84ac-3c6fff9cd940?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/redux-framework/tags/4.5.15/redux-core/inc/classes/class-redux-enqueue.php#L582
  - url: >-
      https://plugins.trac.wordpress.org/browser/redux-framework/tags/4.5.15/redux-core/inc/classes/class-redux-enqueue.php#L735
  - url: >-
      https://plugins.trac.wordpress.org/browser/redux-framework/tags/4.5.15/redux-core/inc/extensions/users/class-redux-extension-users.php#L484
  - url: >-
      https://plugins.trac.wordpress.org/browser/redux-framework/tags/4.5.15/redux-core/inc/extensions/users/class-redux-extension-users.php#L156
  - url: 'https://github.com/reduxframework/redux-framework/pull/4119'
  - url: >-
      https://plugins.trac.wordpress.org/browser/redux-framework/tags/4.5.16/redux-core/inc/classes/class-redux-enqueue.php
tags:
  - cve.org
epss: 0.00276
epssPercentile: 0.20185
ingestedAt: '2026-11-05T16:24:31.541Z'
---

## Overview

The Redux Framework plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.5.15. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to view the entire Redux options payload — including plaintext password field values, API keys, license keys, and SMTP credentials — exposed in the inline redux_&lt;opt_name&gt; JavaScript block on wp-admin/profile.php. The Users extension is loaded automatically for every Redux instance registered by any installed theme or plugin, meaning any site running Redux Framework is affected regardless of whether the developer explicitly configured the Users extension.

## Affected

- `redux_framework <= 4.5.15`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
