---
id: CVE-2026-104062
title: >-
  Scribus before 1.6.7 and 1.7.x before 1.7.4 Heap Buffer Overflow via PICT
  Pixmap Loader
summary: >-
  Scribus before 1.6.7 and 1.7.x before 1.7.4 contains a heap buffer overflow
  vulnerability in the PICT image loader and import plugin that allows attackers
  to corrupt heap memory by supplying an unchecked bytesPerLine value. Attackers
  can…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-787
vendor: Scribus
product: Scribus
affected:
  - Scribus < 1.6.7
  - Scribus >= 1.7.0 < 1.7.4
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-30T18:25:46.423734Z'
published: '2026-10-30'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T20:37:48.045Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-104062'
references:
  - url: >-
      https://github.com/scribusproject/scribus/commit/d667b3b1d38e1808721315dc976d67b72070f6b4
    label: Patch Commit (1.6.x)
  - url: >-
      https://github.com/scribusproject/scribus/commit/544a179241362eb254cb69a5cc68ef24388b265f
    label: Patch Commit (1.7.x)
  - url: 'https://github.com/scribusproject/scribus'
  - url: 'https://wiki.scribus.net/canvas/1.6.7_Release'
  - url: >-
      https://www.vulncheck.com/advisories/scribus-before-1.6.7-heap-buffer-overflow-via-pict-pixmap-loader
    label: >-
      VulnCheck Advisory: Scribus before 1.6.7 Heap Buffer Overflow via PICT
      Pixmap Loader
tags:
  - cve.org
epss: 0.00212
epssPercentile: 0.11581
ingestedAt: '2026-11-05T19:30:42.840Z'
---

## Overview

Scribus before 1.6.7 and 1.7.x before 1.7.4 contains a heap buffer overflow vulnerability in the PICT image loader and import plugin that allows attackers to corrupt heap memory by supplying an unchecked bytesPerLine value. Attackers can craft a PICT file whose bytesPerLine exceeds the QImage scanline size, so placing or importing it crashes Scribus and may execute code as the user.

## Affected

- `Scribus < 1.6.7`
- `Scribus >= 1.7.0 < 1.7.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
