---
id: CVE-2026-104317
title: Langflow OSS is affected by multiple vulnerabilities
summary: >-
  IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote attacker who could
  reach the message broker to execute arbitrary code on the system due to the
  deserialization of untrusted data.
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-502
vendor: IBM
product: Langflow OSS
affected:
  - langflow_oss >= 1.0.0 <= 1.12.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-30T03:56:29.419294Z'
published: '2026-10-29'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T17:18:26.776Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-104317'
references:
  - url: 'https://www.ibm.com/support/pages/node/7293015'
tags:
  - cve.org
epss: 0.00592
epssPercentile: 0.48398
ingestedAt: '2026-11-05T16:24:31.183Z'
---

## Overview

IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote attacker who could reach the message broker to execute arbitrary code on the system due to the deserialization of untrusted data.

## Affected

- `langflow_oss >= 1.0.0 <= 1.12.3`

## Remediation

IBM strongly recommends addressing the vulnerability now by upgrading  Langflow OSS to version 1.12.4. https://pypi.org/project/langflow/1.12.4/ 



For Langflow OSS versions 1.0.0 - 1.12.3, follow the  Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the  Langflow OSS installation instructions https://docs.langflow.org/get-started-installation  to install version 1.12.4 and test your flows.
