---
id: CVE-2026-104713
title: >-
  Allocation of resources without limits or throttling vulnerability in the
  Apache Struts REST plugin
summary: >-
  Allocation of resources without limits or throttling vulnerability in the
  Apache Struts REST plugin. A request body is read into memory without any
  bound on how much will be accepted, so a single request can cause the server
  to allocate …
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-770
vendor: apache
product: struts
affected:
  - 'struts >= 2.1.8, <= 2.3.37'
  - 'struts >= 2.5.0, <= 2.5.33'
  - 'struts >= 6.0.0, < 6.12.0'
  - 'struts >= 7.0.0, < 7.4.0'
patched:
  - struts 7.4.0
published: '2026-10-05'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T19:15:41.920'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-104713'
references:
  - url: 'https://cwiki.apache.org/confluence/display/WW/S2-077'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/10/05/12'
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
epss: 0.0056
epssPercentile: 0.46419
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-06T14:11:48.988162Z'
ingestedAt: '2026-10-05T19:30:59.978Z'
---

## Overview

Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not use the REST plugin are not affected.

This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0.

Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.

## Affected

- `struts >= 2.1.8, <= 2.3.37`
- `struts >= 2.5.0, <= 2.5.33`
- `struts >= 6.0.0, < 6.12.0`
- `struts >= 7.0.0, < 7.4.0`

## Remediation

Upgrade past the affected range:

- `struts 7.4.0`
