---
id: CVE-2026-104727
title: >-
  Sequential Order Numbers for WooCommerce <= 3.6.5 - Authenticated
  (Contributor+) Stored Cross-Site Scripting via 'condition' Post Meta Array
  Keys
summary: >-
  The Sequential Order Numbers for WooCommerce plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via 'condition' Post Meta Array Keys
  in all versions up to, and including, 3.6.5 due to insufficient input
  sanitization and ou…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: berocket
product: Sequential Order Numbers for WooCommerce
affected:
  - sequential_order_numbers_for_woocommerce <= 3.6.5
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T10:31:53.004762Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T10:45:40.925Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-104727'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/942bceac-0587-4e74-bf3e-12d56dbb2186?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/sequential-order-numbers-for-woocommerce/tags/3.6.5/berocket/templates/conditions.php#L57
  - url: >-
      https://plugins.trac.wordpress.org/browser/sequential-order-numbers-for-woocommerce/tags/3.6.5/berocket/templates/conditions.php#L92
  - url: >-
      https://plugins.trac.wordpress.org/browser/sequential-order-numbers-for-woocommerce/tags/3.6.5/berocket/includes/functions.php#L520
  - url: >-
      https://plugins.trac.wordpress.org/browser/sequential-order-numbers-for-woocommerce/tags/3.6.5/berocket/includes/custom_post.php#L356
  - url: >-
      https://plugins.trac.wordpress.org/browser/sequential-order-numbers-for-woocommerce/tags/3.6.5/includes/custom_post.php#L85
  - url: >-
      https://plugins.trac.wordpress.org/browser/sequential-order-numbers-for-woocommerce/tags/3.7
tags:
  - cve.org
epss: 0.00252
epssPercentile: 0.16729
ingestedAt: '2026-10-31T04:17:25.429Z'
---

## Overview

The Sequential Order Numbers for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'condition' Post Meta Array Keys in all versions up to, and including, 3.6.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Affected

- `sequential_order_numbers_for_woocommerce <= 3.6.5`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
