---
id: CVE-2026-104735
title: >-
  The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube
  Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via Feedzy Loop Block Feed URL / RSS <title> in all versions up to,
  and in…
summary: >-
  The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube
  Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via Feedzy Loop Block Feed URL / RSS <title> in all versions up to,
  and in…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
published: '2026-10-10'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T13:30:21.620'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-104735'
references:
  - url: 'https://downloads.wordpress.org/plugin/feedzy-rss-feeds.5.2.11.zip'
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.10/includes/abstract/feedzy-rss-feeds-admin-abstract.php#L1758
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.10/includes/gutenberg/feedzy-rss-feeds-loop-block.php#L207
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.10/includes/gutenberg/feedzy-rss-feeds-loop-block.php#L241
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.10/includes/gutenberg/feedzy-rss-feeds-loop-block.php#L262
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/a15a6cf2-aa7d-454c-83d2-9d74ce4505be?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00209
epssPercentile: 0.11069
ingestedAt: '2026-10-10T05:23:33.492Z'
vendor: themeisle
product: >-
  RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video
  Feeds Aggregator
affected:
  - >-
    rss_aggregator_by_feedzy_feed_to_post_autoblogging_news_youtube_video_feeds_aggregator
    <= 5.2.10
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-11T12:17:38.897732Z'
---

## Overview

The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Feedzy Loop Block Feed URL / RSS <title> in all versions up to, and including, 5.2.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is not neutralized at save time because post_content stores only a benign block reference to an external feed URL; the malicious HTML is injected at render time from the attacker-controlled RSS feed title, bypassing any save-time wp_kses filtering.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
