---
id: CVE-2026-104798
title: >-
  The My Calendar – Accessible Event Manager plugin for WordPress is vulnerable
  to Privilege Escalation in all versions up to, and including, 3.8.7
summary: >-
  The My Calendar – Accessible Event Manager plugin for WordPress is vulnerable
  to Privilege Escalation in all versions up to, and including, 3.8.7. The
  public `mcs` GET parameter is reflected into post content unsanitized before
  WordPress…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-269
vendor: joedolson
product: My Calendar – Accessible Event Manager
affected:
  - my_calendar_accessible_event_manager <= 3.4.24
  - my_calendar_accessible_event_manager >= 3.5 <= 3.5.21
  - my_calendar_accessible_event_manager >= 3.6 <= 3.6.17
  - my_calendar_accessible_event_manager >= 3.7 <= 3.7.17
  - my_calendar_accessible_event_manager >= 3.8 <= 3.8.7
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T18:17:20.360'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-104798'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/my-calendar/tags/3.8.6/my-calendar-navigation.php#L248
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/my-calendar/tags/3.8.6/my-calendar-navigation.php#L260
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/my-calendar/tags/3.8.6/my-calendar-output.php#L1622
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/my-calendar/tags/3.8.6/my-calendar-search.php#L170
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/my-calendar/tags/3.8.6/my-calendar-search.php#L221
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/my-calendar/tags/3.8.6/my-calendar-shortcodes.php#L102
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3746389%40my-calendar&new=3746389%40my-calendar
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/e8aa6ee7-525e-4458-9f5b-1e729afe448c?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00471
epssPercentile: 0.40905
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-16T16:48:56.803700Z'
ingestedAt: '2026-10-16T04:58:47.490Z'
---

## Overview

The My Calendar – Accessible Event Manager plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.8.7. The public `mcs` GET parameter is reflected into post content unsanitized before WordPress core's `do_shortcode` filter runs, allowing an unauthenticated attacker to inject a nested `[my_calendar above=...]` shortcode; `mc_generate_calendar_nav()` then splits the `above` attribute on commas and dispatches each element via `call_user_func()` with no authentication, authorization, or callable allowlist check. This makes it possible for unauthenticated attackers to invoke arbitrary loaded PHP functions, enabling a call chain in which the shortcode `$params` array is passed to `edit_user()` — which PHP coerces to integer `1` as the `$user_id` argument — overwriting the credentials of the initial Administrator account (user ID 1) and granting the attacker full wp-admin access. Exploitation is trivially reachable via the plugin's auto-generated `/my-calendar/` page, which is publicly accessible by default upon plugin activation.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
