---
id: CVE-2026-104932
title: >-
  The Search Regex plugin for WordPress is vulnerable to PHP Object Injection in
  version 3.5 via deserialization of untrusted input in the replace_all function
summary: >-
  The Search Regex plugin for WordPress is vulnerable to PHP Object Injection in
  version 3.5 via deserialization of untrusted input in the replace_all
  function. This allows authenticated attackers, with subscriber-level access
  and above, t…
severity: high
cvss: 8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-502
vendor: johnny5
product: Search Regex
affected:
  - search_regex <= 3.5
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:03.793'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-104932'
references:
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&new=3730910%40search-regex%2Ftags%2F3.5.1&old=3729403%40search-regex%2Ftags%2F3.5
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/cb801c72-0e50-4df1-88cc-30f8037c6d3c?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00282
epssPercentile: 0.20626
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-16T14:53:04.311414Z'
ingestedAt: '2026-10-16T06:00:00.388Z'
---

## Overview

The Search Regex plugin for WordPress is vulnerable to PHP Object Injection in version 3.5 via deserialization of untrusted input in the replace_all function. This allows authenticated attackers, with subscriber-level access and above, to inject a PHP Object. The additional presence of a POP chain allows attackers to execute code.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
