---
id: CVE-2026-105077
title: >-
  WordPress Ad Inserter plugin <= 2.8.19 - Cross Site Scripting (XSS)
  vulnerability
summary: Unauthenticated Cross Site Scripting (XSS) in Ad Inserter <= 2.8.19 versions.
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: Spacetime
product: ad-inserter
affected:
  - ad-inserter >= n/a <= 2.8.19
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T18:45:41.150807Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T19:00:18.568Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-105077'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/ad-inserter/vulnerability/wordpress-ad-inserter-plugin-2-8-19-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
epss: 0.00228
epssPercentile: 0.13738
ingestedAt: '2026-11-05T16:24:31.397Z'
---

## Overview

Unauthenticated Cross Site Scripting (XSS) in Ad Inserter <= 2.8.19 versions.

## Affected

- `ad-inserter >= n/a <= 2.8.19`

## Remediation

Update to 2.8.20 or a higher version.
