---
id: CVE-2026-10511
title: >-
  Jupiter X Core <= 4.61.0 - Authenticated (Contributor+) Stored Cross-Site
  Scripting via 'forget_password_link' Parameter
summary: >-
  The Jupiter X Core plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'forget_password_link' parameter in all versions up to, and
  including, 4.61.0 due to insufficient input sanitization and output escaping.
  This m…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-80
vendor: artbees
product: Jupiter X Core
affected:
  - jupiter_x_core <= 4.61.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T01:34:25.717853Z'
published: '2026-10-27'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T01:52:00.657Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-10511'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/7736342c-21e8-42e6-8af8-31c69ff7781e?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/jupiterx-core/tags/4.15.0/includes/extensions/raven/includes/modules/forms/widgets/login.php#L736
  - url: >-
      https://plugins.trac.wordpress.org/browser/jupiterx-core/tags/4.15.0/includes/extensions/raven/includes/modules/forms/widgets/login.php#L648
  - url: >-
      https://plugins.trac.wordpress.org/browser/jupiterx-core/tags/4.15.0/includes/extensions/raven/includes/modules/forms/widgets/login.php#L401
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3759312/jupiterx-core/trunk/includes/extensions/raven/includes/modules/forms/widgets/login.php
tags:
  - cve.org
epss: 0.00193
epssPercentile: 0.09039
ingestedAt: '2026-10-27T16:11:59.241Z'
---

## Overview

The Jupiter X Core plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'forget_password_link' parameter in all versions up to, and including, 4.61.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Affected

- `jupiter_x_core <= 4.61.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
