---
id: CVE-2026-105221
title: >-
  The gist RubyGem before 6.1.0 contains an improper certificate validation
  vulnerability that allows on-path attackers to intercept HTTPS traffic because
  http_connection in lib/gist.rb sets VERIFY_NONE
summary: >-
  The gist RubyGem before 6.1.0 contains an improper certificate validation
  vulnerability that allows on-path attackers to intercept HTTPS traffic because
  http_connection in lib/gist.rb sets VERIFY_NONE. Attackers can present any
  certifica…
severity: high
cvss: 7.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N'
cwe:
  - CWE-295
vendor: defunkt
product: gist
affected:
  - gist >= 4.0.0 < 6.1.0
published: '2026-10-04'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T16:08:43.180'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105221'
references:
  - url: 'https://github.com/defunkt/gist'
    label: disclosure@vulncheck.com
  - url: 'https://github.com/defunkt/gist/blob/v6.0.0/lib/gist.rb#L466-L468'
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/defunkt/gist/commit/07ccc1a6d46e9d36f0e85d0b1c5d795890ae6bcf
    label: disclosure@vulncheck.com
  - url: 'https://github.com/defunkt/gist/issues/373'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/gist-rubygem-before-6.1.0-disabled-tls-certificate-verification
    label: disclosure@vulncheck.com
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-105221.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-105221'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-105221'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105221'
tags:
  - nvd
  - exploit-available
  - cve.org
  - csaf
  - vex
  - red-hat
epss: 0.00226
epssPercentile: 0.13436
exploits:
  github: 1
  githubRepos:
    - 'https://github.com/abraxas/cve-2026-105221-gist-tls'
  checkedAt: '2026-11-06T16:54:04.997Z'
exploitAvailable: true
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-05T19:18:30.694491Z'
ingestedAt: '2026-10-04T23:05:36.217Z'
---

## Overview

The gist RubyGem before 6.1.0 contains an improper certificate validation vulnerability that allows on-path attackers to intercept HTTPS traffic because http_connection in lib/gist.rb sets VERIFY_NONE. Attackers can present any certificate to read or modify GitHub API traffic, stealing OAuth tokens and login credentials to read and modify the victim's gists.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Vendor advisories

- **Red Hat VEX** · updated 2026-10-06 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-105221.json)
