---
id: CVE-2026-105442
title: >-
  IBM WebSphere Application Server 8.5, and 9.0 and IBM WebSphere Application
  Server - Liberty 17.0.0.3 through 26.0.0.10 Liberty could allow a remote
  attacker to cause a denial of service caused by an insecure deserialization in
  the messa…
summary: >-
  IBM WebSphere Application Server 8.5, and 9.0 and IBM WebSphere Application
  Server - Liberty 17.0.0.3 through 26.0.0.10 Liberty could allow a remote
  attacker to cause a denial of service caused by an insecure deserialization in
  the messa…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-502
published: '2026-10-13'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T17:18:15.073'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105442'
references:
  - url: 'https://www.ibm.com/support/pages/node/7292221'
    label: psirt@us.ibm.com
tags:
  - nvd
  - cve.org
epss: 0.00395
epssPercentile: 0.335
ingestedAt: '2026-10-13T21:58:14.168Z'
vendor: IBM
product: WebSphere Application Server
affected:
  - websphere_application_server 8.5
  - websphere_application_server 9.0
  - websphere_application_server_-_liberty >= 17.0.0.3 <= 26.0.0.10
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-14T16:55:21.531162Z'
---

## Overview

IBM WebSphere Application Server 8.5, and 9.0 and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.10 Liberty could allow a remote attacker to cause a denial of service caused by an insecure deserialization in the messaging service.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
