---
id: CVE-2026-105643
title: Ghost is a Node.js content management system
summary: >-
  Ghost is a Node.js content management system. From version 6.34.0 until
  6.67.0, embed cards in the Ghost editor could bypass protections against
  stored cross-site scripting. Any staff user, including Contributors, could
  store scripts in …
severity: high
cvss: 7.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N'
cwe:
  - CWE-79
  - CWE-653
vendor: TryGhost
product: Ghost
affected:
  - 'Ghost >= 6.34.0, < 6.67.0'
published: '2026-10-05'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T17:17:17.913'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105643'
references:
  - url: 'https://github.com/TryGhost/Ghost/security/advisories/GHSA-69qc-f5m6-889c'
    label: security-advisories@github.com
  - url: 'https://github.com/penpot/penpot/security/advisories/GHSA-qvq5-c536-pmx8'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105643'
  - url: 'https://github.com/advisories/GHSA-69qc-f5m6-889c'
tags:
  - nvd
  - cve.org
  - ghsa
  - npm
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-06T16:55:12.677779Z'
epss: 0.00277
epssPercentile: 0.20017
ingestedAt: '2026-10-05T19:30:59.980Z'
aliases:
  - GHSA-69qc-f5m6-889c
ecosystem: npm
patched:
  - ghost 6.67.0
---

## Overview

Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new  security.embedPreviewUrl  configuration option at its default value. This issue is fixed in version 6.67.0.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-105643)

Affected packages:

- `ghost >= 6.34.0, < 6.67.0`

Patched in:

- `ghost 6.67.0`

Source: https://github.com/advisories/GHSA-69qc-f5m6-889c
