---
id: CVE-2026-105650
title: Ghost is a Node.js content management system
summary: >-
  Ghost is a Node.js content management system. From 2.1.0 until 6.64.0,
  embedding a URL from an attacker-controlled website could result in untrusted
  scripts being stored in post content. These scripts could run in the Ghost
  editor, on th…
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N'
cwe:
  - CWE-79
  - CWE-184
vendor: TryGhost
product: Ghost
affected:
  - 'Ghost >= 2.5.0, < 6.64.0'
published: '2026-10-05'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T15:03:59.427'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105650'
references:
  - url: >-
      https://github.com/TryGhost/Ghost/commit/d23d552e257e2696c60293bc5cd7898a49d6bd1f
    label: security-advisories@github.com
  - url: 'https://github.com/TryGhost/Ghost/pull/30763'
    label: security-advisories@github.com
  - url: 'https://github.com/TryGhost/Ghost/releases/tag/v6.64.0'
    label: security-advisories@github.com
  - url: 'https://github.com/TryGhost/Ghost/security/advisories/GHSA-v3xr-g6p2-fvgv'
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105650'
  - url: 'https://github.com/advisories/GHSA-v3xr-g6p2-fvgv'
tags:
  - nvd
  - cve.org
  - ghsa
  - npm
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-06T13:38:21.403014Z'
ingestedAt: '2026-10-05T19:30:59.997Z'
aliases:
  - GHSA-v3xr-g6p2-fvgv
ecosystem: npm
patched:
  - ghost 6.64.0
epss: 0.00328
epssPercentile: 0.25737
---

## Overview

Ghost is a Node.js content management system. From 2.1.0 until 6.64.0, embedding a URL from an attacker-controlled website could result in untrusted scripts being stored in post content. These scripts could run in the Ghost editor, on the published site, and in newsletter emails, possibly resulting in compromise of a staff user's admin session. This issue is fixed in version 6.64.0.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-105650)

Affected packages:

- `ghost >= 2.5.0, < 6.64.0`

Patched in:

- `ghost 6.64.0`

Source: https://github.com/advisories/GHSA-v3xr-g6p2-fvgv
