---
id: CVE-2026-105697
title: Langflow is a tool for building and deploying AI-powered agents and workflows
summary: >-
  Langflow is a tool for building and deploying AI-powered agents and workflows.
  Before Langflow 1.10.3, the MCP stdio transport launched whatever command /
  args a user put in an MCP server configuration, with no allowlist and (before
  1.10…
severity: critical
cvss: 9.9
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H'
cwe:
  - CWE-78
vendor: langflow
product: langflow
affected:
  - 'langflow >= 1.1.2, < 1.10.3'
  - 'langflow-base >= 0.1.2, < 0.10.3'
  - lfx < 1.10.3
patched:
  - langflow 1.10.3
  - langflow-base 0.10.3
  - lfx 1.10.3
published: '2026-10-05'
updated: '2026-10-09'
sourceUpdated: '2026-10-09T20:17:09.307'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105697'
references:
  - url: >-
      https://github.com/langflow-ai/langflow/commit/eba285edf1dd4a33bf23a9cb8113c991fcdf3d1d
    label: security-advisories@github.com
  - url: >-
      https://github.com/langflow-ai/langflow/commit/efbc4a16e639409d938a4883463d27ef0bc637a0
    label: security-advisories@github.com
  - url: 'https://github.com/langflow-ai/langflow/pull/12290'
    label: security-advisories@github.com
  - url: 'https://github.com/langflow-ai/langflow/pull/14036'
    label: security-advisories@github.com
  - url: 'https://github.com/langflow-ai/langflow/releases/tag/v1.10.3'
    label: security-advisories@github.com
  - url: >-
      https://github.com/langflow-ai/langflow/security/advisories/GHSA-7w94-79vh-5mr2
    label: security-advisories@github.com
  - url: >-
      https://github.com/langflow-ai/langflow/security/advisories/GHSA-w794-rj3p-xv45
    label: security-advisories@github.com
  - url: >-
      https://www.ox.security/blog/mcp-supply-chain-advisory-rce-vulnerabilities-across-the-ai-ecosystem
    label: security-advisories@github.com
  - url: >-
      https://www.ox.security/blog/the-mother-of-all-ai-supply-chains-critical-systemic-vulnerability-at-the-core-of-the-mcp
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105697'
  - url: 'https://github.com/advisories/GHSA-w794-rj3p-xv45'
  - url: 'https://github.com/langflow-ai/langflow'
  - url: 'https://pypi.org/project/langflow'
  - url: 'https://pypi.org/project/langflow-base'
  - url: 'https://pypi.org/project/lfx'
tags:
  - nvd
  - ghsa
  - pip
  - cve.org
  - osv
  - exploit-available
aliases:
  - GHSA-w794-rj3p-xv45
  - PYSEC-2026-4237
  - PYSEC-2026-4239
  - PYSEC-2026-4241
ecosystem: pip
epss: 0.00787
epssPercentile: 0.55948
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-06T14:36:02.678305Z'
ingestedAt: '2026-10-05T21:34:25.113Z'
exploitAvailable: true
---

## Overview

Langflow is a tool for building and deploying AI-powered agents and workflows. Before Langflow 1.10.3, the MCP stdio transport launched whatever command / args a user put in an MCP server configuration, with no allowlist and (before 1.10.3) wrapped in bash -c "exec {command} ...". Any user able to reach the MCP server settings ("Settings → MCP Servers → Add MCP Server", POST/PATCH /api/v2/mcp/servers/{server_name}) or to build a flow with the MCP Tools component could add a "server" whose command is an arbitrary OS command (touch, rm -rf, a reverse shell, ...). The command runs on the Langflow host as the Langflow process user as soon as Langflow tries to connect to the server (listing servers, loading tools, running the flow) — even when the UI then reports that the stdio server failed to start. With the default LANGFLOW_AUTO_LOGIN=true, GET /api/v1/auto_login hands out a token without credentials, so on an exposed instance running the default configuration this is reachable without an account. AUTO_LOGIN is documented as a development-only setting; with it disabled, any authenticated (non-admin) user can exploit it. This issue is fixed in Langflow 1.10.3, langflow-base 0.10.3, and lfx 1.10.3.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-105697)

Affected packages:

- `langflow >= 1.1.2, < 1.10.3`
- `langflow-base >= 0.1.2, < 0.10.3`
- `lfx < 1.10.3`

Patched in:

- `langflow 1.10.3`
- `langflow-base 0.10.3`
- `lfx 1.10.3`

Source: https://github.com/advisories/GHSA-w794-rj3p-xv45
