---
id: CVE-2026-105848
title: Payload is a free and open source headless content management system
summary: >-
  Payload is a free and open source headless content management system. In
  @payloadcms/plugin-stripe versions before 3.90.0 and canary versions before
  4.0.0-canary.34, an authenticated user who can reach the enabled optional
  Stripe REST pr…
severity: critical
cvss: 9.6
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N'
cwe:
  - CWE-749
  - CWE-862
vendor: payloadcms
product: payload
affected:
  - payload < 3.90.0
  - payload = 4.0.0
patched:
  - payload 3.90.0
published: '2026-10-06'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T00:13:23.133'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105848'
references:
  - url: >-
      https://github.com/payloadcms/payload/commit/2f94a4205e5ba3ec0e91c92ed54f24f429826dd0
    label: security-advisories@github.com
  - url: 'https://github.com/payloadcms/payload/releases/tag/v3.90.0'
    label: security-advisories@github.com
  - url: >-
      https://github.com/payloadcms/payload/security/advisories/GHSA-r9v2-gg2j-22q5
    label: security-advisories@github.com
  - url: 'https://github.com/advisories/GHSA-r9v2-gg2j-22q5'
tags:
  - nvd
  - ghsa
  - npm
  - cve.org
  - score-dispute
epss: 0.00244
epssPercentile: 0.15511
aliases:
  - GHSA-r9v2-gg2j-22q5
ecosystem: npm
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-09T01:10:12.482093Z'
scores:
  nvd: 9.6
  cna: 6.4
ingestedAt: '2026-10-06T17:09:22.184Z'
---

## Overview

Payload is a free and open source headless content management system. In @payloadcms/plugin-stripe versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user who can reach the enabled optional Stripe REST proxy can perform unintended Stripe operations. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

## Affected

- `payload < 3.90.0`
- `payload = 4.0.0`

## Remediation

Upgrade past the affected range:

- `payload 3.90.0`

## Package advisory (CVE-2026-105848)

Affected packages:

- `@payloadcms/plugin-stripe < 3.90.0`
- `@payloadcms/plugin-stripe >= 4.0.0-canary.0, < 4.0.0-canary.34`

Patched in:

- `@payloadcms/plugin-stripe 3.90.0`
- `@payloadcms/plugin-stripe 4.0.0-canary.34`

Source: https://github.com/advisories/GHSA-r9v2-gg2j-22q5
