---
id: CVE-2026-105857
title: Payload is a free and open source headless content management system
summary: >-
  Payload is a free and open source headless content management system. In
  @payloadcms/plugin-form-builder versions before 3.90.0 and canary versions
  before 4.0.0-canary.34, an attacker can craft a form submission that executes
  code remote…
severity: critical
cvss: 10
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H'
cwe:
  - CWE-94
  - CWE-1321
vendor: payloadcms
product: payload
affected:
  - payload < 3.90.0
  - payload = 4.0.0
patched:
  - payload 3.90.0
published: '2026-10-06'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T00:11:25.630'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105857'
references:
  - url: >-
      https://github.com/payloadcms/payload/commit/333b82b9f3e685fed6826c2e3270da79df8336c6
    label: security-advisories@github.com
  - url: 'https://github.com/payloadcms/payload/releases/tag/v3.90.0'
    label: security-advisories@github.com
  - url: >-
      https://github.com/payloadcms/payload/security/advisories/GHSA-r488-j9vj-wx3q
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105857'
  - url: 'https://github.com/advisories/GHSA-r488-j9vj-wx3q'
tags:
  - nvd
  - cve.org
  - ghsa
  - npm
epss: 0.00429
epssPercentile: 0.36936
aliases:
  - GHSA-r488-j9vj-wx3q
ecosystem: npm
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-06T17:23:21.462360Z'
ingestedAt: '2026-10-06T17:09:22.199Z'
---

## Overview

Payload is a free and open source headless content management system. In @payloadcms/plugin-form-builder versions before 3.90.0 and canary versions before 4.0.0-canary.34, an attacker can craft a form submission that executes code remotely on the server. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

## Affected

- `payload < 3.90.0`
- `payload = 4.0.0`

## Remediation

Upgrade past the affected range:

- `payload 3.90.0`

## Package advisory (CVE-2026-105857)

Affected packages:

- `@payloadcms/plugin-form-builder < 3.90.0`
- `@payloadcms/plugin-form-builder >= 4.0.0-canary.0, < 4.0.0-canary.34`

Patched in:

- `@payloadcms/plugin-form-builder 3.90.0`
- `@payloadcms/plugin-form-builder 4.0.0-canary.34`

Source: https://github.com/advisories/GHSA-r488-j9vj-wx3q
