---
id: CVE-2026-105858
title: Payload is a free and open source headless content management system
summary: >-
  Payload is a free and open source headless content management system. In
  versions before 3.90.0 and canary versions before 4.0.0-canary.34, a crafted
  request to the public first-register operation can execute code remotely when
  local aut…
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-94
  - CWE-1321
vendor: payloadcms
product: payload
affected:
  - payload < 3.90.0
  - payload = 4.0.0
patched:
  - payload 3.90.0
published: '2026-10-06'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T00:11:17.267'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105858'
references:
  - url: >-
      https://github.com/payloadcms/payload/commit/e947fc4ba4a434f276d043386e501b1d14eda679
    label: security-advisories@github.com
  - url: 'https://github.com/payloadcms/payload/releases/tag/v3.90.0'
    label: security-advisories@github.com
  - url: >-
      https://github.com/payloadcms/payload/security/advisories/GHSA-97rh-rhh2-7vjv
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105858'
  - url: 'https://github.com/advisories/GHSA-97rh-rhh2-7vjv'
tags:
  - nvd
  - cve.org
  - ghsa
  - npm
epss: 0.00475
epssPercentile: 0.40887
aliases:
  - GHSA-97rh-rhh2-7vjv
ecosystem: npm
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-09T01:13:53.118550Z'
ingestedAt: '2026-10-06T17:09:22.197Z'
---

## Overview

Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, a crafted request to the public first-register operation can execute code remotely when local authentication is enabled and no initial user has been created. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

## Affected

- `payload < 3.90.0`
- `payload = 4.0.0`

## Remediation

Upgrade past the affected range:

- `payload 3.90.0`

## Package advisory (CVE-2026-105858)

Affected packages:

- `payload < 3.90.0`
- `payload >= 4.0.0-canary.0, < 4.0.0-canary.34`

Patched in:

- `payload 3.90.0`
- `payload 4.0.0-canary.34`

Source: https://github.com/advisories/GHSA-97rh-rhh2-7vjv
