---
id: CVE-2026-105861
title: Payload is a free and open source headless content management system
summary: >-
  Payload is a free and open source headless content management system. In
  versions after 3.0.0 and before 3.90.0, authenticated external URL-based
  upload retrieval can forward authentication data to a redirected destination
  that was not v…
severity: high
cvss: 8.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N'
cwe:
  - CWE-200
  - CWE-346
vendor: payloadcms
product: payload
affected:
  - 'payload >= 3.0.0, < 3.90.0'
  - payload = 4.0.0
patched:
  - payload 3.90.0
published: '2026-10-06'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T00:09:43.197'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105861'
references:
  - url: >-
      https://github.com/payloadcms/payload/commit/ba5cf6ae20d27a2c15106cb37466419031f86e6d
    label: security-advisories@github.com
  - url: 'https://github.com/payloadcms/payload/releases/tag/v3.90.0'
    label: security-advisories@github.com
  - url: >-
      https://github.com/payloadcms/payload/security/advisories/GHSA-pj5h-5q6c-3pfx
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105861'
  - url: 'https://github.com/advisories/GHSA-pj5h-5q6c-3pfx'
tags:
  - nvd
  - cve.org
  - ghsa
  - npm
epss: 0.00133
epssPercentile: 0.02841
aliases:
  - GHSA-pj5h-5q6c-3pfx
ecosystem: npm
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-06T17:34:13.957850Z'
scores:
  nvd: 8.2
  cna: 7.2
ingestedAt: '2026-10-06T17:09:22.195Z'
---

## Overview

Payload is a free and open source headless content management system. In versions after 3.0.0 and before 3.90.0, authenticated external URL-based upload retrieval can forward authentication data to a redirected destination that was not verified as trusted, potentially exposing a valid session to an unintended recipient. This issue is fixed in version 3.90.0.

## Affected

- `payload >= 3.0.0, < 3.90.0`
- `payload = 4.0.0`

## Remediation

Upgrade past the affected range:

- `payload 3.90.0`

## Package advisory (CVE-2026-105861)

Affected packages:

- `payload >= 3.0.0, < 3.90.0`
- `payload >= 4.0.0-canary.0, < 4.0.0-canary.34`

Patched in:

- `payload 3.90.0`
- `payload 4.0.0-canary.34`

Source: https://github.com/advisories/GHSA-pj5h-5q6c-3pfx
