---
id: CVE-2026-105866
title: Payload is a free and open source headless content management system
summary: >-
  Payload is a free and open source headless content management system. In
  versions before 3.90.0 and canary versions before 4.0.0-canary.34, an
  unauthenticated attacker who knows an account email address or username can
  abuse the account …
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-307
  - CWE-645
vendor: payloadcms
product: payload
affected:
  - payload < 3.90.0
  - payload = 4.0.0
patched:
  - payload 3.90.0
published: '2026-10-06'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T00:08:37.490'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105866'
references:
  - url: >-
      https://github.com/payloadcms/payload/commit/1c46204a73a0a9f988a80c52690eee5a4ada3cf1
    label: security-advisories@github.com
  - url: 'https://github.com/payloadcms/payload/releases/tag/v3.90.0'
    label: security-advisories@github.com
  - url: >-
      https://github.com/payloadcms/payload/security/advisories/GHSA-v5gf-vpjc-pc7w
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-105866'
  - url: 'https://github.com/advisories/GHSA-v5gf-vpjc-pc7w'
tags:
  - nvd
  - cve.org
  - ghsa
  - npm
epss: 0.00369
epssPercentile: 0.30573
aliases:
  - GHSA-v5gf-vpjc-pc7w
ecosystem: npm
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-06T17:34:37.543263Z'
scores:
  nvd: 7.5
  cna: 6.9
ingestedAt: '2026-10-06T17:09:22.189Z'
---

## Overview

Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, an unauthenticated attacker who knows an account email address or username can abuse the account lockout mechanism of a local-authentication collection to prevent that account from signing in. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

## Affected

- `payload < 3.90.0`
- `payload = 4.0.0`

## Remediation

Upgrade past the affected range:

- `payload 3.90.0`

## Package advisory (CVE-2026-105866)

Affected packages:

- `payload < 3.90.0`
- `payload >= 4.0.0-canary.0, < 4.0.0-canary.34`

Patched in:

- `payload 3.90.0`
- `payload 4.0.0-canary.34`

Source: https://github.com/advisories/GHSA-v5gf-vpjc-pc7w
