---
id: CVE-2026-105894
title: >-
  Ak Framework <= 2.9.8 - Authenticated (Subscriber+) Missing Authorization to
  Arbitrary Options Update
summary: >-
  The Ak Framework plugin for WordPress, included in the Newsy - Viral News &
  Magazine WordPress Theme, is vulnerable to Privilege Escalation in all
  versions up to, and including, 2.9.8. This is due to missing capability checks
  in the ajax…
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-269
vendor: akbilisim
product: Ak Framework
affected:
  - ak_framework <= 2.9.8
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-30T17:30:50.428484Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T18:08:56.279Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-105894'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/d9f99ab9-eb22-4766-81f2-647af1229815?source=cve
  - url: 'https://docs.akbilisim.com/newsy/changelog/#v299'
tags:
  - cve.org
epss: 0.00318
epssPercentile: 0.24869
ingestedAt: '2026-11-05T16:24:31.301Z'
---

## Overview

The Ak Framework plugin for WordPress, included in the Newsy - Viral News & Magazine WordPress Theme, is vulnerable to Privilege Escalation in all versions up to, and including, 2.9.8. This is due to missing capability checks in the ajax_refresh_nonce and ak_admin_ajax handlers before passing attacker-controlled option names and values to update_option(). This makes it possible for unauthenticated attackers to update arbitrary WordPress options including users_can_register and default_role to escalate privileges to administrator by enabling user registration with administrator as the default role.

## Affected

- `ak_framework <= 2.9.8`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
