---
id: CVE-2026-106095
title: >-
  The Code Snippets WordPress plugin before 3.10.0 does not perform a capability
  check on one of its snippet-management actions and derives the network scope
  of the targeted snippet from the request instead of from the stored record,
  allow…
summary: >-
  The Code Snippets WordPress plugin before 3.10.0 does not perform a capability
  check on one of its snippet-management actions and derives the network scope
  of the targeted snippet from the request instead of from the stored record,
  allow…
severity: low
cvss: 3.3
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:L'
cwe:
  - CWE-862
published: '2026-10-09'
updated: '2026-10-09'
sourceUpdated: '2026-10-09T15:17:08.340'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-106095'
references:
  - url: 'https://wpscan.com/vulnerability/4aeddbb6-d7a9-48cb-96ea-5898586bce04/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
epss: 0.00159
epssPercentile: 0.04978
ingestedAt: '2026-10-09T07:28:22.264Z'
product: Code Snippets
affected:
  - code_snippets < 3.10.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-09T14:45:21.101534Z'
---

## Overview

The Code Snippets WordPress plugin before 3.10.0 does not perform a capability check on one of its snippet-management actions and derives the network scope of the targeted snippet from the request instead of from the stored record, allowing an administrator of a single subsite on a multisite network to activate, deactivate and reprioritise network-scoped snippets that run across every site in the network.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
