---
id: CVE-2026-106098
title: >-
  The WP Data Access  WordPress plugin before 5.5.77 does not correctly check
  authorization on one of its application REST endpoints, verifying only read
  permission before performing a write, which allows unauthenticated attackers
  to modif…
summary: >-
  The WP Data Access  WordPress plugin before 5.5.77 does not correctly check
  authorization on one of its application REST endpoints, verifying only read
  permission before performing a write, which allows unauthenticated attackers
  to modif…
severity: medium
cvss: 5.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N'
cwe:
  - CWE-863
published: '2026-10-14'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T16:14:02.800'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-106098'
references:
  - url: 'https://wpscan.com/vulnerability/f062a098-c00c-49f8-a32a-58b18ebcebe2/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
ingestedAt: '2026-10-14T07:21:04.833Z'
product: WP Data Access
affected:
  - wp_data_access < 5.5.77
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-14T13:31:21.487132Z'
epss: 0.00239
epssPercentile: 0.14876
---

## Overview

The WP Data Access  WordPress plugin before 5.5.77 does not correctly check authorization on one of its application REST endpoints, verifying only read permission before performing a write, which allows unauthenticated attackers to modify data in an application exposed for anonymous read access even when update actions have been disabled by the administrator.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
