---
id: CVE-2026-106490
title: Backstage is an open framework for building developer portals
summary: >-
  Backstage is an open framework for building developer portals. Prior to 2.2.4,
  the @backstage/plugin-techdocs-backend package is affected by improper input
  validation in techdocs static content requests. When using the Azure Blob
  Storage…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-22
  - CWE-23
vendor: backstage
product: backstage
affected:
  - backstage < 1.54.6
  - plugin-techdocs-backend < 2.2.4
published: '2026-10-06'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T17:16:49.213'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-106490'
references:
  - url: >-
      https://github.com/backstage/backstage/commit/40ecc4c2e88b0218125b0a3405d1f6315b321974
    label: security-advisories@github.com
  - url: 'https://github.com/backstage/backstage/releases/tag/v1.54.6'
    label: security-advisories@github.com
  - url: >-
      https://github.com/backstage/backstage/security/advisories/GHSA-7mfx-xg57-53c9
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-106490'
  - url: 'https://github.com/advisories/GHSA-7mfx-xg57-53c9'
tags:
  - nvd
  - cve.org
  - ghsa
  - npm
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-07T15:27:11.195983Z'
epss: 0.00369
epssPercentile: 0.31025
ingestedAt: '2026-10-06T21:20:28.984Z'
aliases:
  - GHSA-7mfx-xg57-53c9
ecosystem: npm
patched:
  - '@backstage/plugin-techdocs-backend 2.2.4'
---

## Overview

Backstage is an open framework for building developer portals. Prior to 2.2.4, the @backstage/plugin-techdocs-backend package is affected by improper input validation in techdocs static content requests. When using the Azure Blob Storage provider, an authenticated Backstage user may be able to read restricted TechDocs content when entity-level permissions are enabled. Deployments that intentionally disable the default backend authentication policy may have broader exposure. This issue is fixed in version 2.2.4.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-106490)

Affected packages:

- `@backstage/plugin-techdocs-backend < 2.2.4`

Patched in:

- `@backstage/plugin-techdocs-backend 2.2.4`

Source: https://github.com/advisories/GHSA-7mfx-xg57-53c9
