---
id: CVE-2026-106491
title: Backstage is an open framework for building developer portals
summary: >-
  Backstage is an open framework for building developer portals. Prior to
  0.6.17, the @backstage/plugin-proxy-backend package is affected by improper
  input validation in proxy-backend. An authenticated Backstage user could craft
  a request …
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-20
  - CWE-22
vendor: backstage
product: '@backstage/plugin-proxy-backend'
affected:
  - '@backstage/plugin-proxy-backend < 0.6.17'
patched:
  - '@backstage/plugin-proxy-backend 0.6.17'
published: '2026-10-06'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T18:17:16.360'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-106491'
references:
  - url: >-
      https://github.com/backstage/backstage/commit/233287d0ce3133e41549bf92a7470c940a41753c
    label: security-advisories@github.com
  - url: 'https://github.com/backstage/backstage/releases/tag/v1.54.6'
    label: security-advisories@github.com
  - url: >-
      https://github.com/backstage/backstage/security/advisories/GHSA-9ghw-48h5-v2w5
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-106491'
  - url: 'https://github.com/advisories/GHSA-9ghw-48h5-v2w5'
tags:
  - nvd
  - ghsa
  - npm
  - cve.org
aliases:
  - GHSA-9ghw-48h5-v2w5
ecosystem: npm
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-07T17:51:57.186407Z'
epss: 0.00275
epssPercentile: 0.19742
ingestedAt: '2026-10-06T21:20:28.985Z'
---

## Overview

Backstage is an open framework for building developer portals. Prior to 0.6.17, the @backstage/plugin-proxy-backend package is affected by improper input validation in proxy-backend. An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the configured base path on the target server. This is limited to target servers already configured as proxy endpoints and requires Backstage authentication by default. This issue is fixed in version 0.6.17.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-106491)

Affected packages:

- `@backstage/plugin-proxy-backend < 0.6.17`

Patched in:

- `@backstage/plugin-proxy-backend 0.6.17`

Source: https://github.com/advisories/GHSA-9ghw-48h5-v2w5
