---
id: CVE-2026-106498
title: Backstage is an open framework for building developer portals
summary: >-
  Backstage is an open framework for building developer portals. Prior to 3.5.1,
  3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package
  is affected by improper url validation in catalog entity placeholder
  resolution. …
severity: high
cvss: 7.7
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N'
cwe:
  - CWE-863
  - CWE-918
vendor: linuxfoundation
product: backstage_plugin-catalog-backend
affected:
  - backstage_plugin-catalog-backend < 3.5.1
  - 'backstage_plugin-catalog-backend >= 3.6.0, < 3.6.2'
  - 'backstage_plugin-catalog-backend >= 3.7.0, < 3.7.2'
  - 'backstage_plugin-catalog-backend >= 3.8.0, < 3.8.2'
  - 'backstage_plugin-catalog-backend >= 3.9.0, < 3.9.1'
  - backstage < 1.49.6
  - 'backstage >= 1.50.0, < 1.50.5'
  - 'backstage >= 1.51.0, < 1.51.3'
  - 'backstage >= 1.52.0, < 1.53.2'
  - 'backstage >= 1.54.0, < 1.54.6'
patched:
  - backstage_plugin-catalog-backend 3.9.1
  - backstage 1.54.6
published: '2026-10-06'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:22:13.790'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-106498'
references:
  - url: >-
      https://github.com/backstage/backstage/commit/0b0f6fc89b4eb4872c76a498abbe1dc65998bb6e
    label: security-advisories@github.com
  - url: >-
      https://github.com/backstage/backstage/commit/286bfc1f9cc3608a073b41016be302785be385d1
    label: security-advisories@github.com
  - url: >-
      https://github.com/backstage/backstage/commit/61a10f19926aeda7f4a32de48d733e6710584634
    label: security-advisories@github.com
  - url: >-
      https://github.com/backstage/backstage/commit/99729e925fd2bd40ba210022351a0ee6318e6197
    label: security-advisories@github.com
  - url: >-
      https://github.com/backstage/backstage/commit/e786ac309ed2d775daf2309393c015c43902d6f6
    label: security-advisories@github.com
  - url: 'https://github.com/backstage/backstage/releases/tag/v1.49.6'
    label: security-advisories@github.com
  - url: 'https://github.com/backstage/backstage/releases/tag/v1.50.5'
    label: security-advisories@github.com
  - url: 'https://github.com/backstage/backstage/releases/tag/v1.51.3'
    label: security-advisories@github.com
  - url: 'https://github.com/backstage/backstage/releases/tag/v1.53.2'
    label: security-advisories@github.com
  - url: 'https://github.com/backstage/backstage/releases/tag/v1.54.6'
    label: security-advisories@github.com
  - url: >-
      https://github.com/backstage/backstage/security/advisories/GHSA-qgvj-qcf8-xq73
    label: security-advisories@github.com
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-106498.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-106498'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2547215'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-106498'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-106498'
  - url: 'https://github.com/advisories/GHSA-qgvj-qcf8-xq73'
tags:
  - nvd
  - cve.org
  - csaf
  - vex
  - red-hat
  - ghsa
  - npm
  - score-dispute
epss: 0.00307
epssPercentile: 0.23353
aliases:
  - GHSA-qgvj-qcf8-xq73
ecosystem: npm
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-09T01:54:51.540668Z'
scores:
  nvd: 7.7
  vendor: 4.3
  ghsa: 7.7
  cna: 7.7
ingestedAt: '2026-10-06T22:23:15.966Z'
---

## Overview

Backstage is an open framework for building developer portals. Prior to 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package is affected by improper url validation in catalog entity placeholder resolution. An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. This issue is fixed in versions 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1.

## Affected

- `backstage_plugin-catalog-backend < 3.5.1`
- `backstage_plugin-catalog-backend >= 3.6.0, < 3.6.2`
- `backstage_plugin-catalog-backend >= 3.7.0, < 3.7.2`
- `backstage_plugin-catalog-backend >= 3.8.0, < 3.8.2`
- `backstage_plugin-catalog-backend >= 3.9.0, < 3.9.1`
- `backstage < 1.49.6`
- `backstage >= 1.50.0, < 1.50.5`
- `backstage >= 1.51.0, < 1.51.3`
- `backstage >= 1.52.0, < 1.53.2`
- `backstage >= 1.54.0, < 1.54.6`

## Remediation

Upgrade past the affected range:

- `backstage_plugin-catalog-backend 3.9.1`
- `backstage 1.54.6`

## Package advisory (CVE-2026-106498)

Affected packages:

- `@backstage/plugin-catalog-backend < 3.9.1`

Patched in:

- `@backstage/plugin-catalog-backend 3.9.1`

Source: https://github.com/advisories/GHSA-qgvj-qcf8-xq73

## Vendor advisories

- **Red Hat VEX** · Moderate · affected: Red Hat Developer Hub, Self-service automation portal 2 · no fix planned: Red Hat Developer Hub, Self-service automation portal 2 · updated 2026-10-07 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-106498.json)
