---
id: CVE-2026-106504
title: Backstage is an open framework for building developer portals
summary: >-
  Backstage is an open framework for building developer portals. Prior to 4.1.0,
  the @backstage/plugin-scaffolder-backend package is affected by sensitive
  information exposure in scaffolder task logs. An authenticated user who can
  create a…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-532
vendor: linuxfoundation
product: backstage/plugin-scaffolder-backend
affected:
  - backstage/plugin-scaffolder-backend < 4.1.0
  - backstage < 1.54.6
patched:
  - backstage/plugin-scaffolder-backend 4.1.0
  - backstage 1.54.6
published: '2026-10-06'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T21:08:57.650'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-106504'
references:
  - url: >-
      https://github.com/backstage/backstage/commit/3eb3dc59eb0da0deccd532f19eb460bb452c9efb
    label: security-advisories@github.com
  - url: 'https://github.com/backstage/backstage/releases/tag/v1.54.6'
    label: security-advisories@github.com
  - url: >-
      https://github.com/backstage/backstage/security/advisories/GHSA-4xvq-3m68-h444
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-106504'
  - url: 'https://github.com/advisories/GHSA-4xvq-3m68-h444'
tags:
  - nvd
  - ghsa
  - npm
  - cve.org
epss: 0.00257
epssPercentile: 0.17298
aliases:
  - GHSA-4xvq-3m68-h444
ecosystem: npm
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-07T16:20:37.738464Z'
ingestedAt: '2026-10-06T22:23:15.968Z'
---

## Overview

Backstage is an open framework for building developer portals. Prior to 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by sensitive information exposure in scaffolder task logs. An authenticated user who can create and read scaffolder tasks may be able to observe sensitive values in task logs in deployments with restrictive action permissions and affected templates. Exploitation requires a denied action whose input contains such a value. This issue is fixed in version 4.1.0.

## Affected

- `backstage/plugin-scaffolder-backend < 4.1.0`
- `backstage < 1.54.6`

## Remediation

Upgrade past the affected range:

- `backstage/plugin-scaffolder-backend 4.1.0`
- `backstage 1.54.6`

## Package advisory (CVE-2026-106504)

Affected packages:

- `@backstage/plugin-scaffolder-backend < 4.1.0`

Patched in:

- `@backstage/plugin-scaffolder-backend 4.1.0`

Source: https://github.com/advisories/GHSA-4xvq-3m68-h444
