---
id: CVE-2026-107158
title: >-
  The LTL Freight Quotes  WordPress plugin before 4.2.19 does not perform any
  authorization check or validation on one of its REST routes that writes to the
  database, allowing unauthenticated users to modify some of the LTL Freight
  Quotes …
summary: >-
  The LTL Freight Quotes  WordPress plugin before 4.2.19 does not perform any
  authorization check or validation on one of its REST routes that writes to the
  database, allowing unauthenticated users to modify some of the LTL Freight
  Quotes …
severity: medium
cvss: 5.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N'
cwe:
  - CWE-862
published: '2026-10-14'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T16:14:02.800'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-107158'
references:
  - url: 'https://wpscan.com/vulnerability/e4c4700a-25c6-4f8f-b017-ea32a81ffcb6/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
ingestedAt: '2026-10-14T07:21:04.836Z'
product: LTL Freight Quotes
affected:
  - ltl_freight_quotes < 4.2.19
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-14T13:30:12.786776Z'
epss: 0.00282
epssPercentile: 0.20616
---

## Overview

The LTL Freight Quotes  WordPress plugin before 4.2.19 does not perform any authorization check or validation on one of its REST routes that writes to the database, allowing unauthenticated users to modify some of the LTL Freight Quotes  WordPress plugin before 4.2.19's stored settings.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
