---
id: CVE-2026-107291
title: >-
  Pydantic AI is a Python agent framework for building applications and
  workflows with Generative AI
summary: >-
  Pydantic AI is a Python agent framework for building applications and
  workflows with Generative AI. From 0.3.4 until 1.107.6 and 2.44.0,
  OpenTelemetry instrumentation configured with
  InstrumentationSettings(include_content=False) can sti…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'
cwe:
  - CWE-212
  - CWE-532
vendor: pydantic
product: pydantic_ai
affected:
  - 'pydantic_ai >= 0.3.4, < 1.107.4'
  - 'pydantic_ai >= 2.0.0, < 2.44.0'
patched:
  - pydantic_ai 2.44.0
published: '2026-10-08'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T14:34:22.207'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-107291'
references:
  - url: >-
      https://github.com/pydantic/pydantic-ai/commit/4e013c51a50659aba2adf7853bfb22bb77f6a518
    label: security-advisories@github.com
  - url: >-
      https://github.com/pydantic/pydantic-ai/commit/6b14c74cb281f899a2ae4fae5327111e33f60771
    label: security-advisories@github.com
  - url: >-
      https://github.com/pydantic/pydantic-ai/commit/7ee27e38ab2e525ca60ff1a25d16413ff989fd79
    label: security-advisories@github.com
  - url: >-
      https://github.com/pydantic/pydantic-ai/commit/963dec5f70d6f558997fc259356c0090cc5ea487
    label: security-advisories@github.com
  - url: >-
      https://github.com/pydantic/pydantic-ai/commit/de4e61515327bd80a19cd8552001c30933e6acc3
    label: security-advisories@github.com
  - url: 'https://github.com/pydantic/pydantic-ai/pull/8403'
    label: security-advisories@github.com
  - url: 'https://github.com/pydantic/pydantic-ai/pull/8404'
    label: security-advisories@github.com
  - url: 'https://github.com/pydantic/pydantic-ai/pull/8408'
    label: security-advisories@github.com
  - url: 'https://github.com/pydantic/pydantic-ai/pull/8428'
    label: security-advisories@github.com
  - url: 'https://github.com/pydantic/pydantic-ai/pull/8429'
    label: security-advisories@github.com
  - url: 'https://github.com/pydantic/pydantic-ai/releases/tag/v1.107.6'
    label: security-advisories@github.com
  - url: 'https://github.com/pydantic/pydantic-ai/releases/tag/v2.44.0'
    label: security-advisories@github.com
  - url: >-
      https://github.com/pydantic/pydantic-ai/security/advisories/GHSA-4x9p-g9wm-8q7f
    label: security-advisories@github.com
  - url: 'https://github.com/advisories/GHSA-4x9p-g9wm-8q7f'
  - url: 'https://github.com/pydantic/pydantic-ai'
  - url: 'https://pypi.org/project/pydantic-ai'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-107291'
  - url: 'https://pypi.org/project/pydantic-ai-slim'
tags:
  - nvd
  - ghsa
  - pip
  - cve.org
  - osv
  - score-dispute
epss: 0.00622
epssPercentile: 0.49592
aliases:
  - GHSA-4x9p-g9wm-8q7f
  - PYSEC-2026-4275
  - PYSEC-2026-4284
ecosystem: pip
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-08T17:25:09.227835Z'
scores:
  nvd: 4.3
  cna: 2.3
ingestedAt: '2026-10-08T16:52:14.778Z'
---

## Overview

Pydantic AI is a Python agent framework for building applications and workflows with Generative AI. From 0.3.4 until 1.107.6 and 2.44.0, OpenTelemetry instrumentation configured with InstrumentationSettings(include_content=False) can still export sensitive agent content through exception.message and exception.stacktrace events, error status descriptions, and model_request_parameters containing instructions or the prompted_output_template. The exposed data is available to readers of the configured telemetry backend and can include tool feedback, provider error bodies, runtime instructions, and structured-output templates even though message attributes are redacted. This issue does not grant new access to agent data, and deployments that do not use include_content=False are not affected by the setting bypass. This issue is fixed in versions 1.107.6 and 2.44.0.

## Affected

- `pydantic_ai >= 0.3.4, < 1.107.4`
- `pydantic_ai >= 2.0.0, < 2.44.0`

## Remediation

Upgrade past the affected range:

- `pydantic_ai 2.44.0`

## Package advisory (CVE-2026-107291)

Affected packages:

- `pydantic-ai >= 0.3.4, < 1.107.6`
- `pydantic-ai >= 2.0.0b1, < 2.44.0`
- `pydantic-ai-slim >= 0.3.4, < 1.107.6`
- `pydantic-ai-slim >= 2.0.0b1, < 2.44.0`

Patched in:

- `pydantic-ai 1.107.6`
- `pydantic-ai 2.44.0`
- `pydantic-ai-slim 1.107.6`
- `pydantic-ai-slim 2.44.0`

Source: https://github.com/advisories/GHSA-4x9p-g9wm-8q7f
