---
id: CVE-2026-107457
title: Memory corruption vulnerability in QMqttClient impacts Qt MQTT
summary: "A memory corruption vulnerability in the QMqttClient class of the Qt MQTT module.\_Under certain MQTT 5 connection settings between client and server, QMqttClient may corrupt memory, which can cause the application to crash."
severity: low
cvss: 2.3
cvssVector: >-
  CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/R:U/RE:L/U:Green
cvssSource: cna
cwe:
  - CWE-787
  - CWE-129
vendor: qt
product: Qt
affected:
  - Qt >= 5.12.0 <= 6.8.8
  - Qt >= 6.9.0 <= 6.11.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-02T19:21:42.698312Z'
published: '2026-11-02'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T19:21:56.150Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-107457'
references:
  - url: >-
      https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-107457:
  - url: 'https://codereview.qt-project.org/c/qt/qtmqtt/+/762286'
tags:
  - cve.org
epss: 0.00263
epssPercentile: 0.18188
ingestedAt: '2026-11-05T19:30:42.792Z'
---

## Overview

A memory corruption vulnerability in the QMqttClient class of the Qt MQTT module. Under certain MQTT 5 connection settings between client and server, QMqttClient may corrupt memory, which can cause the application to crash.

## Affected

- `Qt >= 5.12.0 <= 6.8.8`
- `Qt >= 6.9.0 <= 6.11.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
