---
id: CVE-2026-107630
title: >-
  Email Templates Customizer and Designer for WordPress and WooCommerce <=
  1.5.14 - Missing Authorization to Unauthenticated Order PII Disclosure via
  'preview_order' Parameter
summary: >-
  The Email Templates Customizer and Designer for WordPress and WooCommerce
  plugin for WordPress is vulnerable to authorization bypass in all versions up
  to, and including, 1.5.14 This is due to the plugin not properly verifying
  that a use…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-862
vendor: saadiqbal
product: Email Templates Customizer and Designer for WordPress and WooCommerce
affected:
  - >-
    email_templates_customizer_and_designer_for_wordpress_and_woocommerce <=
    1.5.14
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-30T17:25:24.817939Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T17:25:36.608Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-107630'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/52eaab58-1e94-4f71-9896-dc2154b00e8e?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/email-templates/tags/1.5.14/includes/woocommerce-customizer/class-mailtpl-woomail-preview.php#L873
  - url: >-
      https://plugins.trac.wordpress.org/browser/email-templates/tags/1.5.14/includes/woocommerce-customizer/class-mailtpl-woomail-preview.php#L293
  - url: >-
      https://plugins.trac.wordpress.org/browser/email-templates/tags/1.5.14/includes/woocommerce-customizer/class-mailtpl-woomail-preview.php#L236
  - url: >-
      https://plugins.trac.wordpress.org/browser/email-templates/tags/1.5.14/admin/class-mailtpl-admin.php#L54
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3770280/email-templates/trunk/includes/woocommerce-customizer/class-mailtpl-woomail-preview.php
tags:
  - cve.org
epss: 0.00509
epssPercentile: 0.43603
ingestedAt: '2026-11-05T16:24:31.276Z'
---

## Overview

The Email Templates Customizer and Designer for WordPress and WooCommerce plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.5.14 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to enumerate WooCommerce order IDs via the preview_order parameter and exfiltrate every customer's billing name, address, phone number, and email address. The exploit requires two unauthenticated requests: the first harvests a reusable nonce from the 302 Location header returned by the unguarded admin_init handler, and the second supplies that nonce alongside an arbitrary order ID to the preview endpoint, making full customer PII disclosure trivially achievable without any account or credentials.

## Affected

- `email_templates_customizer_and_designer_for_wordpress_and_woocommerce <= 1.5.14`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
