---
id: CVE-2026-107649
title: >-
  The Events Made Easy plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'event[location_name]' parameter in all versions up to, and
  including, 3.2.22 due to insufficient input sanitization and output escaping
summary: >-
  The Events Made Easy plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'event[location_name]' parameter in all versions up to, and
  including, 3.2.22 due to insufficient input sanitization and output escaping.
  This…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: liedekef
product: Events Made Easy
affected:
  - events_made_easy <= 3.2.22
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:05.340'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-107649'
references:
  - url: >-
      https://github.com/liedekef/events-made-easy/commit/3d9e92f98a9d9e443d65323ec8c86d598b3e34e0
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/events-made-easy/tags/3.2.21/includes/eme-fs.php#L831
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/events-made-easy/tags/3.2.21/includes/eme-fs.php#L867
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/events-made-easy/tags/3.2.21/includes/eme-locations.php#L3082
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/events-made-easy/tags/3.2.21/js/eme_show_maps.js#L208
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&new=3748824%40events-made-easy%2Ftags%2F3.2.23&old=3723758%40events-made-easy%2Ftags%2F3.2.21
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/f80a1fa2-d44b-4101-a891-fce21ee99427?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00221
epssPercentile: 0.12597
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:33:27.374777Z'
ingestedAt: '2026-10-16T10:04:12.093Z'
---

## Overview

The Events Made Easy plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'event[location_name]' parameter in all versions up to, and including, 3.2.22 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when both the guest event submission feature (eme_fs[guest_submit]) and forced location creation (eme_fs[force_location_creation]) are explicitly enabled by a site administrator, as both settings default to off.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
