---
id: CVE-2026-107710
title: >-
  Hustle <= 7.8.14.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
  via Module Content Title
summary: >-
  The Hustle – Email Marketing, Lead Generation, Optins, Popups plugin for
  WordPress is vulnerable to Stored Cross-Site Scripting via the
  'content[title]' parameter in all versions up to, and including, 7.8.14.3 due
  to insufficient input s…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: wpmudev
product: 'Hustle – Email Marketing, Lead Generation, Optins, Popups'
affected:
  - hustle_email_marketing_lead_generation_optins_popups <= 7.8.14.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-28T14:36:38.020063Z'
published: '2026-10-28'
updated: '2026-10-28'
sourceUpdated: '2026-10-28T16:09:34.692Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-107710'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/a3ed1a2a-f9d5-4f34-8a8e-583ea7226df8?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/wordpress-popup/tags/7.8.14.3/inc/front/hustle-module-renderer.php#L181
  - url: >-
      https://plugins.trac.wordpress.org/browser/wordpress-popup/tags/7.8.14.3/inc/front/hustle-module-renderer.php#L163
  - url: >-
      https://plugins.trac.wordpress.org/browser/wordpress-popup/tags/7.8.14.3/inc/hustle-module-model.php#L569
  - url: >-
      https://plugins.trac.wordpress.org/browser/wordpress-popup/tags/7.8.14.3/inc/hustle-modules-common-admin-ajax.php#L49
  - url: >-
      https://plugins.trac.wordpress.org/browser/wordpress-popup/tags/7.8.14.3/inc/front/hustle-module-front.php#L917
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3758337/wordpress-popup/trunk/inc/front/hustle-module-renderer.php
tags:
  - cve.org
epss: 0.00201
epssPercentile: 0.09955
ingestedAt: '2026-10-28T07:06:27.108Z'
---

## Overview

The Hustle – Email Marketing, Lead Generation, Optins, Popups plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content[title]' parameter in all versions up to, and including, 7.8.14.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has explicitly granted the 'Create and Update Modules' (hustle_create / hustle_edit_module) capability to the attacker's role via the plugin's own Settings → Permissions feature; this delegation is not enabled by default.

## Affected

- `hustle_email_marketing_lead_generation_optins_popups <= 7.8.14.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
