---
id: CVE-2026-107711
title: >-
  FlexStock <= 3.17.2 - Authenticated (Subscriber+) Stored Cross-Site Scripting
  via 'post_content' Parameter via REST update endpoint
summary: >-
  The FlexStock – Product Stock Sync with Google Sheets for WooCommerce plugin
  for WordPress is vulnerable to Stored Cross-Site Scripting via the
  'products[].post_content' parameter in all versions up to, and including,
  3.17.2 due to insuf…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: wppool
product: FlexStock – Product Stock Sync with Google Sheets for WooCommerce
affected:
  - flexstock_product_stock_sync_with_google_sheets_for_woocommerce <= 3.17.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-01T17:33:50.078364Z'
published: '2026-10-31'
updated: '2026-11-01'
sourceUpdated: '2026-11-01T17:34:18.153Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-107711'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/b03cabc6-1cbe-4aa2-8eae-cea30d01b811?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/stock-sync-with-google-sheet-for-woocommerce/tags/3.17.2/includes/models/class-product.php#L1500
  - url: >-
      https://plugins.trac.wordpress.org/browser/stock-sync-with-google-sheet-for-woocommerce/tags/3.17.2/includes/classes/class-api.php#L577
  - url: >-
      https://plugins.trac.wordpress.org/browser/stock-sync-with-google-sheet-for-woocommerce/tags/3.17.2/includes/classes/class-api.php#L79
  - url: >-
      https://plugins.trac.wordpress.org/browser/stock-sync-with-google-sheet-for-woocommerce/tags/3.17.2/includes/classes/class-hooks.php#L1184
  - url: >-
      https://plugins.trac.wordpress.org/browser/stock-sync-with-google-sheet-for-woocommerce/tags/3.17.2/includes/classes/class-app.php#L458
  - url: >-
      https://plugins.trac.wordpress.org/browser/stock-sync-with-google-sheet-for-woocommerce/tags/3.17.2/includes/helper/functions.php#L139
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3768111/stock-sync-with-google-sheet-for-woocommerce/trunk/includes/models/class-product.php
tags:
  - cve.org
epss: 0.00342
epssPercentile: 0.27867
ingestedAt: '2026-11-05T18:28:50.807Z'
---

## Overview

The FlexStock – Product Stock Sync with Google Sheets for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'products[].post_content' parameter in all versions up to, and including, 3.17.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is exploitable by any Subscriber-level user because the plugin's admin_enqueue_scripts callback exposes the REST bearer token in the Dashboard page source via wp_localize_script() without a capability check, and the REST endpoint's permission_callback validates only that bearer token rather than performing a current_user_can() capability check.

## Affected

- `flexstock_product_stock_sync_with_google_sheets_for_woocommerce <= 3.17.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
