---
id: CVE-2026-107746
title: >-
  The FunnelKit – Funnel Builder for WooCommerce Checkout plugin for WordPress
  is vulnerable to authorization bypass in all versions up to, and including,
  3.16.0.6 This is due to the plugin not properly verifying that a user is
  authorized …
summary: >-
  The FunnelKit – Funnel Builder for WooCommerce Checkout plugin for WordPress
  is vulnerable to authorization bypass in all versions up to, and including,
  3.16.0.6 This is due to the plugin not properly verifying that a user is
  authorized …
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-862
vendor: teamfunnelkit
product: FunnelKit – Funnel Builder Plugin for WooCommerce Checkout
affected:
  - funnelkit_funnel_builder_plugin_for_woocommerce_checkout <= 3.16.0.6
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T16:16:57.983'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-107746'
references:
  - url: 'https://downloads.wordpress.org/plugin/funnel-builder.3.17.0.zip'
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/funnel-builder/tags/3.16.0.5/modules/thankyou-pages/class-wffn-thank-you-wc-pages.php#L429
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/funnel-builder/tags/3.16.0.5/modules/thankyou-pages/includes/class-wfty-data.php#L286
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/funnel-builder/tags/3.16.0.5/modules/thankyou-pages/includes/class-wfty-data.php#L318
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/funnel-builder/tags/3.16.0.5/modules/thankyou-pages/includes/class-wfty-data.php#L328
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/bc9883b7-ea99-41e4-adf6-a3988f616a3f?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00318
epssPercentile: 0.24532
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-16T15:49:31.146847Z'
ingestedAt: '2026-10-16T04:58:47.492Z'
---

## Overview

The FunnelKit – Funnel Builder for WooCommerce Checkout plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.16.0.6 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to retrieve billing PII — including full name, street address, email address, and phone number — for any WooCommerce order on the site by submitting an enumerable sequential order ID. This is only exploitable on sites where a FunnelKit thank-you page exists that renders the [wfty_order_meta] or [wfty_order_total] shortcode.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
