---
id: CVE-2026-107758
title: >-
  The Colibri Page Builder plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via the 'comment' parameter in all versions up to, and
  including, 1.0.390 due to insufficient input sanitization and output escaping
summary: >-
  The Colibri Page Builder plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via the 'comment' parameter in all versions up to, and
  including, 1.0.390 due to insufficient input sanitization and output escaping.
  This makes i…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: extendthemes
product: Colibri Page Builder
affected:
  - colibri_page_builder <= 1.0.390
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:05.540'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-107758'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/assets/static/colibri.js#L205
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/assets/static/colibri.js#L57
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/filters/svg-kses.php#L4
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/filters/svg-kses.php#L68
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/filters/svg-kses.php#L82
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/ccae5cbd-cfe6-48b3-8bcd-0b08ceb94680?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00356
epssPercentile: 0.29518
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:34:55.023232Z'
ingestedAt: '2026-10-16T03:57:49.268Z'
---

## Overview

The Colibri Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 1.0.390 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload survives storage because the widened comment allow-list permits SVG elements with arbitrary data-* attributes; execution occurs because colibri.js, enqueued globally on every front-end page, reads the stored data-target value via jQuery.data() — which HTML-entity-decodes it — and passes the resulting string directly into jQuery(), which parses a leading '<' as HTML and fires the embedded event handler.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
