---
id: CVE-2026-107768
title: >-
  The TranslatePress – Translate Multilingual sites with AI Translation plugin
  for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment'
  parameter in all versions up to, and including, 3.3.7 due to insufficient
  input san…
summary: >-
  The TranslatePress – Translate Multilingual sites with AI Translation plugin
  for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment'
  parameter in all versions up to, and including, 3.3.7 due to insufficient
  input san…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: cozmoslabs
product: TranslatePress – Translate Multilingual sites with AI Translation
affected:
  - translatepress_translate_multilingual_sites_with_ai_translation <= 3.3.7
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:05.770'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-107768'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/translatepress-multilingual/tags/3.3.7/includes/class-translation-render.php#L1355
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/translatepress-multilingual/tags/3.3.7/includes/class-translation-render.php#L1655
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/translatepress-multilingual/tags/3.3.7/includes/class-translation-render.php#L835
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3744262/translatepress-multilingual/trunk/includes/class-translation-render.php
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/5e9733d3-4097-4785-947c-db90a38795b3?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00297
epssPercentile: 0.22247
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:33:57.686695Z'
ingestedAt: '2026-10-16T07:01:11.477Z'
---

## Overview

The TranslatePress – Translate Multilingual sites with AI Translation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 3.3.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the target site to allow unmoderated comment submission on at least one post and to have a secondary language configured — both conditions reflect TranslatePress's primary use case.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
