---
id: CVE-2026-109083
title: 'Apache Syncope: Remote Code Execution via Flowable JUEL expression'
summary: >-
  Improper isolation or compartmentalization vulnerability in Apache Syncope.


  An administrator with adequate entitlements can import arbitrary BPMN process
  definitions via the REST API and then start the process. When a BPMN process
  conta…
severity: none
cwe:
  - CWE-653
vendor: Apache Software Foundation
product: 'org.apache.syncope.ext.flowable:syncope-ext-flowable-bpmn'
affected:
  - >-
    org.apache.syncope.ext.flowable:syncope-ext-flowable-bpmn >= 3.0.0-M0 <=
    3.0.16
  - >-
    org.apache.syncope.ext.flowable:syncope-ext-flowable-bpmn >= 4.0.0-M0 <=
    4.0.8
  - 'org.apache.syncope.ext.flowable:syncope-ext-flowable-bpmn >= 4.1.0 <= 4.1.3'
published: '2026-11-02'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T21:05:09.784Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-109083'
references:
  - url: 'https://lists.apache.org/thread.html/zmzxzxv7wjzn071jgn069y2rqjpcrt3s'
tags:
  - cve.org
epss: 0.00222
epssPercentile: 0.12974
ingestedAt: '2026-11-05T19:30:42.852Z'
---

## Overview

Improper isolation or compartmentalization vulnerability in Apache Syncope.

An administrator with adequate entitlements can import arbitrary BPMN process definitions via the REST API and then start the process. When a BPMN process containing a JUEL expression is imported and started, the expression is executed directly on the server, with no sandbox.



This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0 through 4.1.3.



Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue by rejecting BPMN definitions including expression attributes.

## Affected

- `org.apache.syncope.ext.flowable:syncope-ext-flowable-bpmn >= 3.0.0-M0 <= 3.0.16`
- `org.apache.syncope.ext.flowable:syncope-ext-flowable-bpmn >= 4.0.0-M0 <= 4.0.8`
- `org.apache.syncope.ext.flowable:syncope-ext-flowable-bpmn >= 4.1.0 <= 4.1.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
