---
id: CVE-2026-109147
title: WP Booking System < 2.1.0.3 - Reflected XSS via 'booking_id' Parameter
summary: >-
  The WP Booking System  WordPress plugin before 2.1.0.3 does not validate and
  escape one of its parameters before reflecting it back in an admin page,
  leading to Reflected Cross-Site Scripting which could be used against high
  privilege us…
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'
cvssSource: adp
cwe:
  - CWE-79
product: WP Booking System
affected:
  - wp_booking_system < 2.1.0.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-21T10:21:00.102489Z'
published: '2026-10-21'
updated: '2026-10-21'
sourceUpdated: '2026-10-21T10:35:04.857Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-109147'
references:
  - url: 'https://wpscan.com/vulnerability/2a2e58bd-dc3f-4b6f-9b2d-b6d15cd2e898/'
tags:
  - cve.org
ingestedAt: '2026-10-21T06:42:48.182Z'
epss: 0.00243
epssPercentile: 0.1536
---

## Overview

The WP Booking System  WordPress plugin before 2.1.0.3 does not validate and escape one of its parameters before reflecting it back in an admin page, leading to Reflected Cross-Site Scripting which could be used against high privilege users such as administrators.

## Affected

- `wp_booking_system < 2.1.0.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
