---
id: CVE-2026-109207
title: >-
  The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube
  Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'media:thumbnail@url' parameter in all versions up to, and
  includi…
summary: >-
  The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube
  Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'media:thumbnail@url' parameter in all versions up to, and
  includi…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: themeisle
product: >-
  RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video
  Feeds Aggregator
affected:
  - >-
    rss_aggregator_by_feedzy_feed_to_post_autoblogging_news_youtube_video_feeds_aggregator
    <= 5.2.11
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:06.697'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109207'
references:
  - url: 'https://downloads.wordpress.org/plugin/feedzy-rss-feeds.5.2.12.zip'
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.11/includes/abstract/feedzy-rss-feeds-admin-abstract.php#L2134
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.11/includes/admin/feedzy-rss-feeds-import.php#L1241
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.11/includes/admin/feedzy-rss-feeds-import.php#L2951
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.11/includes/admin/feedzy-rss-feeds-import.php#L3413
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.11/includes/admin/feedzy-rss-feeds-import.php#L989
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/ab1d8bcb-688a-4763-970a-c960925cf0b6?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00307
epssPercentile: 0.23325
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:34:57.621596Z'
ingestedAt: '2026-10-16T03:57:49.268Z'
---

## Overview

The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'media:thumbnail@url' parameter in all versions up to, and including, 5.2.11 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the attacker to control an external RSS feed that the target site has already configured for import; no WordPress account or special plugin configuration is needed beyond that condition.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
