---
id: CVE-2026-109208
title: >-
  LearnPress <= 4.4.10 - Unauthenticated Stored Cross-Site Scripting via
  'quantity' and 'order_comments' Parameters
summary: >-
  The LearnPress – WordPress LMS Plugin for Create and Sell Online Courses
  plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the
  'quantity (REST) / order_comments (checkout)' parameter in all versions up to,
  and includi…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: thimpress
product: LearnPress – WordPress LMS Plugin for Create and Sell Online Courses
affected:
  - learnpress_wordpress_lms_plugin_for_create_and_sell_online_courses <= 4.4.10
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-18T11:07:11.982354Z'
published: '2026-10-17'
updated: '2026-10-18'
sourceUpdated: '2026-10-18T11:12:34.936Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-109208'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/4ac1ddf0-9164-45a8-b1dc-e684b1b4b447?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/learnpress/tags/4.4.10/inc/admin/views/meta-boxes/order/content-tab-preview-exports-invoice.php#L86
  - url: >-
      https://plugins.trac.wordpress.org/browser/learnpress/tags/4.4.10/inc/rest-api/v1/frontend/class-lp-rest-courses-controller.php#L671
  - url: >-
      https://plugins.trac.wordpress.org/browser/learnpress/tags/4.4.10/inc/cart/class-lp-cart.php#L108
  - url: >-
      https://plugins.trac.wordpress.org/browser/learnpress/tags/4.4.10/inc/order/class-lp-order.php#L688
  - url: >-
      https://plugins.trac.wordpress.org/browser/learnpress/tags/4.4.10/inc/class-lp-checkout.php#L390
  - url: >-
      https://plugins.trac.wordpress.org/browser/learnpress/tags/4.4.10/inc/admin/views/meta-boxes/order/details.php#L218
  - url: >-
      https://plugins.trac.wordpress.org/browser/learnpress/tags/4.4.10/assets/src/js/admin/order/refund-order.js#L104
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3750024%40learnpress&new=3750024%40learnpress
tags:
  - cve.org
ingestedAt: '2026-10-17T02:57:58.444Z'
epss: 0.00285
epssPercentile: 0.20856
---

## Overview

The LearnPress – WordPress LMS Plugin for Create and Sell Online Courses plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'quantity (REST) / order_comments (checkout)' parameter in all versions up to, and including, 4.4.10 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. With guest checkout enabled the attack is fully unauthenticated; with guest checkout disabled, any Subscriber-level user can exploit both vectors through their own checkout.

## Affected

- `learnpress_wordpress_lms_plugin_for_create_and_sell_online_courses <= 4.4.10`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
