---
id: CVE-2026-109349
title: >-
  gitoxide gix-pack before 0.75.0 contains a reachable assertion in
  BytesToEntriesIter::new_from_header: the pack header decoder accepts version
  3, but a release-enabled assert_eq! requires version 2
summary: >-
  gitoxide gix-pack before 0.75.0 contains a reachable assertion in
  BytesToEntriesIter::new_from_header: the pack header decoder accepts version
  3, but a release-enabled assert_eq! requires version 2. A malicious remote can
  send a 12-byte …
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H'
cwe:
  - CWE-617
vendor: GitoxideLabs
product: gix-pack
affected:
  - gix-pack < 0.75.0
patched:
  - hardened_images
published: '2026-10-12'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T17:27:24.847'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109349'
references:
  - url: >-
      https://github.com/GitoxideLabs/gitoxide/security/advisories/GHSA-633h-mqjc-8rwg
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/gix-pack-before-0.75.0-reachable-assertion-dos-via-pack-version-3-header
    label: disclosure@vulncheck.com
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-109349.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-109349'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2549829'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-109349'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109349'
  - url: 'https://access.redhat.com/errata/RHSA-2026:83849'
  - url: 'https://access.redhat.com/errata/RHSA-2026:83879'
tags:
  - nvd
  - cve.org
  - csaf
  - vex
  - red-hat
epss: 0.0027
epssPercentile: 0.19105
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-13T16:22:09.256469Z'
ingestedAt: '2026-10-12T18:00:08.210Z'
---

## Overview

gitoxide gix-pack before 0.75.0 contains a reachable assertion in BytesToEntriesIter::new_from_header: the pack header decoder accepts version 3, but a release-enabled assert_eq! requires version 2. A malicious remote can send a 12-byte pack header declaring version 3 to panic the client and abort the clone or fetch.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Vendor advisories

- **RHSA-2026:83849** · Red Hat · fixed in: Red Hat Hardened Images · released 2026-10-16 · [advisory](https://access.redhat.com/errata/RHSA-2026:83849)
- **Red Hat VEX** · Moderate · affected: Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9 · no fix planned: Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9 · updated 2026-10-20 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-109349.json)
- **RHSA-2026:83879** · Red Hat · fixed in: Red Hat Hardened Images · released 2026-10-17 · [advisory](https://access.redhat.com/errata/RHSA-2026:83879)
