---
id: CVE-2026-109388
title: >-
  The HivePress – Business Directory, Listings & Classified Ads Plugin plugin
  for WordPress is vulnerable to Stored Cross-Site Scripting via the 'message'
  parameter in all versions up to, and including, 1.7.32 due to insufficient
  input san…
summary: >-
  The HivePress – Business Directory, Listings & Classified Ads Plugin plugin
  for WordPress is vulnerable to Stored Cross-Site Scripting via the 'message'
  parameter in all versions up to, and including, 1.7.32 due to insufficient
  input san…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: hivepress
product: 'HivePress – Business Directory, Listings & Classified Ads Plugin'
affected:
  - business_directory_listings_classified_ads_plugin <= 1.7.32
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:07.240'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109388'
references:
  - url: >-
      https://github.com/hivepress/hivepress/pull/374/changes/508b1766beb79949ab22dd4a163fafadb4c63e7d
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/hivepress/tags/1.7.32/assets/js/common.js#L1278
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/hivepress/tags/1.7.32/includes/blocks/class-form.php#L89
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/hivepress/tags/1.7.32/includes/components/class-editor.php#L417
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/hivepress/tags/1.7.32/includes/forms/class-form.php#L189
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&new=3747070%40hivepress%2Ftags%2F1.8.0&old=3732142%40hivepress%2Ftags%2F1.7.32
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/5d1937ae-d350-452c-b20e-d85bc88dbe48?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00248
epssPercentile: 0.16047
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:34:00.710695Z'
ingestedAt: '2026-10-16T07:01:11.478Z'
---

## Overview

The HivePress – Business Directory, Listings & Classified Ads Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'message' parameter in all versions up to, and including, 1.7.32 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that the site administrator has enabled user listing submission, and the script executes in the victim's browser at the moment of successful login via the embedded form on the attacker's listing page.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
